summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-02 12:48:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-02 16:33:56 +0100
commit80486d6673c09bc350a79f9c9dc82d88019e8662 (patch)
tree39078bdaf0ea461a1baae7681149caf1dcee00c5
parenteecaf17086510ae68bc495b2d9a06a152347bd69 (diff)
downloadguix-80486d6673c09bc350a79f9c9dc82d88019e8662.tar.gz
gnu: python-prompt-toolkit: Update to 2.0.7.
* gnu/packages/python.scm (python-prompt-toolkit): Update to 2.0.7.
[arguments]: Enable tests; add phase "post-install-check" and delete "check"
phase.
[native-inputs]: Add python-pytest.
-rw-r--r--gnu/packages/python.scm53
1 files changed, 32 insertions, 21 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 27f78a2726..20b1ff69f0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9888,32 +9888,43 @@ collections of data.")
   (package-with-python2 python-backpack))
 
 (define-public python-prompt-toolkit
- (package
-  (name "python-prompt-toolkit")
-  (version "1.0.15")
-  (source
-    (origin
-      (method url-fetch)
-      (uri (pypi-uri "prompt_toolkit" version ".tar.gz"))
-      (sha256
+  (package
+    (name "python-prompt-toolkit")
+    (version "2.0.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "prompt_toolkit" version ".tar.gz"))
+       (sha256
         (base32
-          "05v9h5nydljwpj5nm8n804ms0glajwfy1zagrzqrg91wk3qqi1c5"))))
-  (build-system python-build-system)
-  (arguments
-   '(#:tests? #f)) ; The test suite uses some Windows-specific data types.
-  (propagated-inputs
-   `(("python-wcwidth" ,python-wcwidth)
-     ("python-six" ,python-six)
-     ("python-pygments" ,python-pygments)))
-  (home-page "https://github.com/jonathanslenders/python-prompt-toolkit")
-  (synopsis "Library for building command line interfaces in Python")
-  (description
-    "Prompt-Toolkit is a library for building interactive command line
+         "0fgacqk73w7s932vy46pan2yp8rvjmlkag20xvaydh9mhf6h85zx"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (delete 'check)
+         (add-after 'install 'post-install-check
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             ;; HOME is needed for the test
+             ;; "test_pathcompleter_can_expanduser".
+             (setenv "HOME" "/tmp")
+             (add-installed-pythonpath inputs outputs)
+             (invoke "py.test"))))))
+    (propagated-inputs
+     `(("python-wcwidth" ,python-wcwidth)
+       ("python-six" ,python-six)
+       ("python-pygments" ,python-pygments)))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/jonathanslenders/python-prompt-toolkit")
+    (synopsis "Library for building command line interfaces in Python")
+    (description
+     "Prompt-Toolkit is a library for building interactive command line
 interfaces in Python.  It's like GNU Readline but it also features syntax
 highlighting while typing, out-of-the-box multi-line input editing, advanced
 code completion, incremental search, support for Chinese double-width
 characters, mouse support, and auto suggestions.")
-  (license license:bsd-3)))
+    (license license:bsd-3)))
 
 (define-public python2-prompt-toolkit
   (package-with-python2 python-prompt-toolkit))