summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-26 01:52:55 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-26 01:52:55 +0100
commit88b263465c4baabe1711ca2d1eeffe8527a93cc0 (patch)
tree35034a070b7b9e392d85a12b15ad41e4ec540746
parented24dda76d07f6d714effbc4ff692a4bce62a60e (diff)
downloadguix-88b263465c4baabe1711ca2d1eeffe8527a93cc0.tar.gz
build-system/cmake: Enable parallel tests by default.
* guix/build-system/cmake.scm (cmake-build, cmake-cross-build): Set
the PARALLEL-TESTS? key to #t.
-rw-r--r--guix/build-system/cmake.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/guix/build-system/cmake.scm b/guix/build-system/cmake.scm
index aa0f4187ec..1fc0931a27 100644
--- a/guix/build-system/cmake.scm
+++ b/guix/build-system/cmake.scm
@@ -102,7 +102,7 @@
                       (build-type "RelWithDebInfo")
                       (tests? #t)
                       (test-target "test")
-                      (parallel-build? #t) (parallel-tests? #f)
+                      (parallel-build? #t) (parallel-tests? #t)
                       (validate-runpath? #t)
                       (patch-shebangs? #t)
                       (strip-binaries? #t)
@@ -181,7 +181,7 @@ provides a 'CMakeLists.txt' file as its build system."
                             (build-type "RelWithDebInfo")
                             (tests? #f) ; nothing can be done
                             (test-target "test")
-                            (parallel-build? #t) (parallel-tests? #f)
+                            (parallel-build? #t) (parallel-tests? #t)
                             (validate-runpath? #t)
                             (patch-shebangs? #t)
                             (strip-binaries? #t)