summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-28 22:42:16 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:14 +0200
commitc839da85129858fb7b374c5f903f1d32ae676abc (patch)
tree055b033acde53e82a3142b653b49be82c0813e08
parent2927343183efdcdd6bbd732bb1211540ba6ece51 (diff)
downloadguix-c839da85129858fb7b374c5f903f1d32ae676abc.tar.gz
gnu: ghc-hmatrix: Update to 0.19.0.0.
* gnu/packages/haskell.scm (ghc-hmatrix): Update to 0.19.0.0.
[inputs]: Add ghc-semigroups.
-rw-r--r--gnu/packages/haskell.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index df1746b1a2..76feb10a12 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7675,7 +7675,7 @@ and Fortran complex data types.")
 (define-public ghc-hmatrix
   (package
     (name "ghc-hmatrix")
-    (version "0.18.1.0")
+    (version "0.19.0.0")
     (source
      (origin
        (method url-fetch)
@@ -7683,12 +7683,13 @@ and Fortran complex data types.")
              "https://hackage.haskell.org/package/hmatrix/hmatrix-"
              version ".tar.gz"))
        (sha256
-        (base32 "07zkwvg872hfk6jyn4s54ws8mvclynazaxf7fsbqi16dmf9dn61c"))))
+        (base32 "10jd69nby29dggghcyjk6ykyr5wrn97nrv1dkpyrp0y5xm12xssj"))))
     (build-system haskell-build-system)
     (inputs
      `(("ghc-random" ,ghc-random)
        ("ghc-split" ,ghc-split)
        ("ghc-storable-complex" ,ghc-storable-complex)
+       ("ghc-semigroups" ,ghc-semigroups)
        ("ghc-vector" ,ghc-vector)
        ;;("openblas" ,openblas)
        ("lapack" ,lapack)))