summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-10-13 11:12:33 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-13 11:14:00 +0200
commitdad66da493b13f1999bf22b9661fea76ff969fbf (patch)
tree5020755b7f02270ffc035e0bac91d8a96690f248
parentdc8ddbfb076e769d9a63d458e195c4705188bc0c (diff)
downloadguix-dad66da493b13f1999bf22b9661fea76ff969fbf.tar.gz
gnu: Add plink-ng.
* gnu/packages/bioinformatics.scm (plink-ng): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 112d0e577c..2963dd321d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4889,6 +4889,43 @@ subsequent visualization, annotation and storage of results.")
     ;; LGPLv2.1+
     (license (list license:gpl2 license:lgpl2.1+))))
 
+(define-public plink-ng
+  (package (inherit plink)
+    (name "plink-ng")
+    (version "1.90b4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/chrchang/plink-ng/archive/v"
+                           version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "09ixrds009aczjswxr2alcb774mksq5g0v78dgjjn1h4dky0kf9a"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f ;no "check" target
+       #:make-flags (list "BLASFLAGS=-llapack -lopenblas"
+                          "CFLAGS=-Wall -O2 -DDYNAMIC_ZLIB=1"
+                          "ZLIB=-lz"
+                          "-f" "Makefile.std")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda _ (chdir "1.9") #t))
+         (delete 'configure) ; no "configure" script
+         (replace 'install
+                  (lambda* (#:key outputs #:allow-other-keys)
+                    (let ((bin (string-append (assoc-ref outputs "out")
+                                              "/bin/")))
+                      (install-file "plink" bin)
+                      #t))))))
+    (inputs
+     `(("zlib" ,zlib)
+       ("lapack" ,lapack)
+       ("openblas" ,openblas)))
+    (home-page "https://www.cog-genomics.org/plink/")
+    (license license:gpl3+)))
+
 (define-public smithlab-cpp
   (let ((revision "1")
         (commit "728a097bec88c6f4b8528b685932049e660eff2e"))