summary refs log tree commit diff
diff options
context:
space:
mode:
authorSebastian Schott <sschott@mailbox.org>2020-03-07 16:11:42 +0100
committerChristopher Baines <mail@cbaines.net>2020-03-15 16:41:43 +0000
commitf3465dee986ffab4bba27839b2d1d5d4a050d835 (patch)
tree9368706f9f3a6bd7e7731b36dcdbb8329d167ffd
parent2763f0de41c62623622d2eb9d4c17c04d62afcbd (diff)
downloadguix-f3465dee986ffab4bba27839b2d1d5d4a050d835.tar.gz
gnu: Add python-gphoto2
* gnu/packages/python-xyz.scm (python-gphoto2): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4de78fdf27..3ff7bc45a5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -171,6 +171,28 @@
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-26))
 
+(define-public python-gphoto2
+  (package
+    (name "python-gphoto2")
+    (version "2.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "gphoto2" version))
+              (sha256
+               (base32
+                "118zm25c8mlajfl0pzssnwz4b8lamj9dgymla9rn4nla7l244a0r"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libgphoto2" ,libgphoto2)))
+    (home-page "https://github.com/jim-easterbrook/python-gphoto2")
+    (synopsis "Python interface to libgphoto2")
+    (description "@code{python-gphoto2} is a comprehensive Python interface
+(or binding) to @code{libgphoto2}.  It is built using @code{SWIG} to
+automatically generate the interface code.")
+    (license license:gpl3+)))
+
 (define-public python-colour
   (package
     (name "python-colour")