summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-08 22:05:08 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:48 -0500
commitfc984cf646b20eb02689387e5cb86ead6c578ecf (patch)
tree55c306426a5ef2d0f4ba9c8688813bbbb7dae9fb
parent24cf2a8b1294dd2e2bd87b0ca54b5da5c7bac363 (diff)
downloadguix-fc984cf646b20eb02689387e5cb86ead6c578ecf.tar.gz
gnu: Remove ghc-monadplus.
The package doesn't build, has no reverse dependencies, and does not
work with newer versions of GHC.

* gnu/packages/haskell-xyz.scm (ghc-monadplus): Remove variable.
-rw-r--r--gnu/packages/haskell-xyz.scm20
1 files changed, 0 insertions, 20 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 4b092299be..23a1ea5a36 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6988,26 +6988,6 @@ that are much lighter weight than IO-threads.")
 and other added capabilities layered on top of the @code{Par} monad.")
     (license license:bsd-3)))
 
-(define-public ghc-monadplus
-  (package
-    (name "ghc-monadplus")
-    (version "1.4.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "https://hackage.haskell.org/package/monadplus"
-                           "/monadplus-" version ".tar.gz"))
-       (sha256
-        (base32 "15b5320wdpmdp5slpphnc1x4rhjch3igw245dp2jxbqyvchdavin"))))
-    (build-system haskell-build-system)
-    (home-page "https://hackage.haskell.org/package/monadplus")
-    (synopsis "Filtering and folding over arbitrary MonadPlus instances")
-    (description
-     "This package generalizes many common stream operations such as
-@code{filter}, @code{catMaybes} etc, enabling filtering and folding over
-arbitrary @code{MonadPlus} instances.")
-    (license license:bsd-3)))
-
 (define-public ghc-monadrandom
   (package
     (name "ghc-monadrandom")