summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-15 19:47:47 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-15 19:49:06 +0100
commit15c37077bc3801317c9e40ee3552f6aac67baaa7 (patch)
tree95c0798918f4fffb677a82116505527167afb594
parent8653c1d5574d43bba0ecc7efbbdf0b0ee8264a6c (diff)
downloadguix-15c37077bc3801317c9e40ee3552f6aac67baaa7.tar.gz
gnu: python-hy: Fix test suite.
* gnu/packages/python.scm (python-hy, python2-hy)[arguments]: Replace 'check'
phase with custom command.
[native-inputs]: Add python-coverage and python-nose.
-rw-r--r--gnu/packages/python.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d438e5c6d4..c45afbc2ff 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8273,6 +8273,17 @@ with a new public API, and RPython support.")
                (base32
                 "1msqv747iz12r73mz4qvsmlwkddwjvrahlrk7ysrcz07h7dsscxs"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             ;; Tests require write access to HOME.
+             (setenv "HOME" "/tmp")
+             (zero? (system* "nosetests")))))))
+    (native-inputs
+     `(("python-coverage" ,python-coverage)
+       ("python-nose" ,python-nose)))
     (propagated-inputs
      `(("python-astor" ,python-astor)
        ("python-clint" ,python-clint)