summary refs log tree commit diff
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-01-23 15:59:47 +0000
committerLudovic Courtès <ludo@gnu.org>2017-03-28 22:15:45 +0200
commit169274d5c58cf3ce385d8ce0b64e2ac57a68906c (patch)
tree3f1f5d1b97d00a693892d9a4e1716353d44a2e3f
parent4dcbed572c8ceaca723fbb8938e5dede3c2023ff (diff)
downloadguix-169274d5c58cf3ce385d8ce0b64e2ac57a68906c.tar.gz
gnu: Add lxde-common.
* gnu/packages/lxde.scm (lxde-common): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/lxde.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 9a4fe75966..6862784f4e 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -263,4 +263,28 @@ menu spec-compliant desktop menus for LXDE.")
     (home-page "http://lxde.org")
     (license license:lgpl3)))
 
+(define-public lxde-common
+  (package
+    (name "lxde-common")
+    (version "0.99.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://downloads.sourceforge.net/lxde/"
+                           name "-" version ".tar.xz"))
+       (sha256
+        (base32
+         "0mj84fa3f4ak1jjslrwc2q3ci9zxrxpciggviza9bjb0168brn8w"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("intltool" ,intltool)
+       ("lxmenu-data" ,lxmenu-data)
+       ("lxde-icon-theme" ,lxde-icon-theme)))
+    (synopsis "Common files of the LXDE Desktop")
+    (description
+     "Lxde-common provides common files of the LXDE Desktop.")
+    (home-page "http://lxde.org")
+    (license license:gpl2+)))
+
 ;;; lxde.scm ends here