summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-19 11:15:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-19 11:21:14 +0300
commit2c7802d2e0a81b70fb7c3bd8d1def65c0bd27771 (patch)
tree295ba5bdb0e06c6ddd3acbb3d75172d272610ff1
parent3f17586269d2984bc592a9bd225fb89f4d9742d8 (diff)
downloadguix-2c7802d2e0a81b70fb7c3bd8d1def65c0bd27771.tar.gz
gnu: python-humanfriendly: Don't propagate python-monotonic.
python-monotonic targets python-2 and early versions of python-3.

* gnu/packages/python-xyz.scm (python-humanfriendly)[propagated-inputs]:
Remove python-monotonic.
[properties]: New field.
(python2-humanfriendly): Adjust accordingly.
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 110d303818..cdc09bcc1b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1136,8 +1136,6 @@ multiple Unicode code points, e.g. \"G\" + acute-accent)
     (arguments
      `(;; XXX: Tests depend on coloredlogs, which in turn depends on humanfriendly.
        #:tests? #f))
-    (propagated-inputs
-     `(("python-monotonic" ,python-monotonic)))
     (home-page "https://humanfriendly.readthedocs.io")
     (synopsis "Human-friendly input and output in Python")
     (description
@@ -1146,10 +1144,16 @@ text interfaces more user-friendly.  It includes tools to parse and format
 numbers, file sizes, and timespans, timers for long-running operations, menus
 to allow the user to choose from a list of options, and terminal interaction
 helpers.")
+    (properties `((python2-variant . ,(delay python2-humanfriendly))))
     (license license:expat)))
 
 (define-public python2-humanfriendly
-  (package-with-python2 python-humanfriendly))
+  (let ((base (package-with-python2
+                (strip-python2-variant python-humanfriendly))))
+    (package (inherit base)
+      (propagated-inputs
+       `(("python2-monotonic" ,python2-monotonic)
+         ,@(package-propagated-inputs base))))))
 
 (define-public python-textparser
   (package