summary refs log tree commit diff
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2017-06-19 09:57:32 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-06-25 23:11:16 +0200
commit2da63064271b5b7af24d619ba147c7dabaea15ef (patch)
treea63bdd6131adfa38e8b1a73a4b8003081a3c3ee1
parenta1714ff5c7be5b39e1989fa8160b214c086c60d7 (diff)
downloadguix-2da63064271b5b7af24d619ba147c7dabaea15ef.tar.gz
gnu: hdf5: Update to 1.8.19.
* gnu/packages/maths.scm (hdf5): Update to 1.8.19.
[source]: Update uri.
-rw-r--r--gnu/packages/maths.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1115cef598..9bdb068774 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -608,12 +608,13 @@ incompatible with HDF5.")
 (define-public hdf5
   (package
     (name "hdf5")
-    (version "1.8.18")
+    (version "1.8.19")
     (source
      (origin
       (method url-fetch)
-      (uri (list (string-append "http://www.hdfgroup.org/ftp/HDF5/releases/"
-                                "hdf5-" version "/src/hdf5-"
+      (uri (list (string-append "https://support.hdfgroup.org/ftp/HDF5/releases/"
+                                "hdf5-" (version-major+minor version)
+                                "/hdf5-" version "/src/hdf5-"
                                 version ".tar.bz2")
                  (string-append "https://support.hdfgroup.org/ftp/HDF5/"
                                 "current"
@@ -621,7 +622,7 @@ incompatible with HDF5.")
                                        (take (string-split version #\.) 2))
                                 "/src/hdf5-" version ".tar.bz2")))
       (sha256
-       (base32 "13542vrnl1p35n8vbq0wzk40vddmm33q5nh04j98c7r1yjnxxih1"))
+       (base32 "0f3jfbqpaaq21ighi40qzs52nb52kc2d2yjk541rjmsx20b3ih2r"))
       (patches (list (search-patch "hdf5-config-date.patch")))))
     (build-system gnu-build-system)
     (inputs