summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-04-07 10:48:49 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-04-07 10:49:30 +0300
commit32c055fd32059cbe0ab6f94eb3ef3a8c7e49dc92 (patch)
treed064bee574d2a2595077378ee1cedb97f61ec887
parent31d663a14b1318eb90cc4f802414739adfe5e54e (diff)
downloadguix-32c055fd32059cbe0ab6f94eb3ef3a8c7e49dc92.tar.gz
gnu: terminology: Run test suite.
* gnu/packages/enlightenment.scm (terminology)[arguments]: Add
configure-flag to build the test binary.  Use custom 'check phase.  Add
phase to remove test binary.
-rw-r--r--gnu/packages/enlightenment.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index e162b20dca..790be1a59e 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -204,11 +204,24 @@ removable devices or support for multimedia.")
                   #t))))
     (build-system meson-build-system)
     (arguments
-     '(#:phases
+     `(#:configure-flags '("-Dtests=true")
+       #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'set-home-directory
            ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
-           (lambda _ (setenv "HOME" "/tmp") #t)))))
+           (lambda _ (setenv "HOME" "/tmp") #t))
+         (replace 'check
+           (lambda _
+             (with-directory-excursion
+               (string-append "../" ,name "-" ,version "/tests")
+               (invoke "sh" "run_tests.sh" "--verbose"
+                       "-t" "../../build/src/bin/tytest"))))
+         (add-after 'install 'remove-test-binary
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; This file is not meant to be installed.
+             (delete-file (string-append (assoc-ref outputs "out")
+                                         "/bin/tytest"))
+             #t)))))
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("perl" ,perl)