summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-15 17:26:42 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-15 17:26:42 +0100
commit35d56b7b607f6de615d5e13eb05273c649ee4543 (patch)
tree7aca00c0cdadc0724c24154e9b2ae8152c6915ad
parentbfba083684e80d2bc23e3c07205e3d63910e978f (diff)
downloadguix-35d56b7b607f6de615d5e13eb05273c649ee4543.tar.gz
gnu: python-sqlalchemy-utils: Disable tests.
* gnu/packages/python.scm (python-sqlalchemy-utils,
  python2-sqlalchemy-utils)[arguments]: Set #:tests? #f.
  [native-inputs]: Add python-dateutil-2, python-flexmock, python-pcycopg2 and
  python-pytz.
-rw-r--r--gnu/packages/python.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 55274783ff..011483d897 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3988,11 +3988,22 @@ both of which are installed automatically if you install this library.")
          (base32
           "1wghyvk73cmq3iqyg3fczw128fv2pan2v76m0xg1bw05h8fhvnk3"))))
     (build-system python-build-system)
+    (arguments
+     '(#:tests? #f)) ; FIXME: Many tests require a running database server.
+       ;; #:phases
+       ;; (modify-phases %standard-phases
+       ;;   (replace 'check
+       ;;     (lambda _
+       ;;       (zero? (system* "py.test" "sqlalchemy_utils" "tests")))))
     (propagated-inputs
      `(("python-six" ,python-six)
        ("python-sqlalchemy" ,python-sqlalchemy)))
     (native-inputs
-     `(("python-pytest" ,python-pytest)))
+     `(("python-dateutil" ,python-dateutil-2)
+       ("python-flexmock" ,python-flexmock)
+       ("python-psycopg2" ,python-psycopg2)
+       ("python-pytest" ,python-pytest)
+       ("python-pytz" ,python-pytz)))
     (home-page "https://github.com/kvesteri/sqlalchemy-utils")
     (synopsis "Various utility functions for SQLAlchemy")
     (description