summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-14 12:59:40 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-14 12:59:40 +0100
commit497355dc09449426ef4fda521433002ec93c4796 (patch)
tree1894b284ee7547db55234e994ffe8d7766d2e76d
parent63b02364aa259e58169b0c4af7e860f7b1ceebd2 (diff)
downloadguix-497355dc09449426ef4fda521433002ec93c4796.tar.gz
gnu: python-nbconvert: Disable tests.
* gnu/packages/python.scm (python-nbconvert, python2-nbconvert)[arguments]:
Set #:tests? #f.
[native-inputs]: Add python-pytest.
-rw-r--r--gnu/packages/python.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9b7d5d99a0..540a988234 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6911,9 +6911,19 @@ functions to find and load entry points.")
         (base32
          "0brclbb18l4nmd5qy3dl9wn05rjdh1fz4rmzdlfqacj12rcdvdgp"))))
     (build-system python-build-system)
-    ;; The "bdist_egg" target is disabled by default, causing the installation
-    ;; to fail.
-    (arguments `(#:configure-flags (list "bdist_egg")))
+    (arguments
+     `(;; The "bdist_egg" target is disabled by default, causing the installation
+       ;; to fail.
+       #:configure-flags (list "bdist_egg")
+       ;; FIXME: 5 failures, 40 errors.
+       #:tests? #f))
+       ;; #:phases
+       ;; (modify-phases %standard-phases
+       ;;   (replace 'check
+       ;;     (lambda _
+       ;;       (zero? (system* "py.test" "-v")))))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
     (propagated-inputs
      `(("python-bleach" ,python-bleach)
        ("python-entrypoints" ,python-entrypoints)