summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-12-14 08:48:38 +0100
committerLudovic Courtès <ludo@gnu.org>2016-12-14 08:48:38 +0100
commit4fbd0f4f86df30b6522260f727b39eaa8a3d1e52 (patch)
tree82d11b253af175fa8f27fc045cb4d90c5c7b75ae
parente8a463e646a8dd21578abe0bc92437d4c2b65c25 (diff)
downloadguix-4fbd0f4f86df30b6522260f727b39eaa8a3d1e52.tar.gz
gnu: guile-next: Update to 2.1.5.
* gnu/packages/guile.scm (guile-next): Update to 2.1.5.
[properties]: Add 'upstream-name', 'ftp-server', and 'ftp-directory'.
-rw-r--r--gnu/packages/guile.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 1c1b35c34b..758b277cbb 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -230,7 +230,7 @@ without requiring the source code to be rewritten.")
 (define-public guile-next
   (package (inherit guile-2.0)
     (name "guile-next")
-    (version "2.1.4")
+    (version "2.1.5")
     (replacement #f)
     (source (origin
               (method url-fetch)
@@ -238,7 +238,7 @@ without requiring the source code to be rewritten.")
                                   version ".tar.xz"))
               (sha256
                (base32
-                "1w8kyy8nz6489d092fix6lvgjrk0bww7i0c2k67ym4hq0kjl0r1j"))
+                "0r9y4hw17dlxahik4zsccfb2f3p2a07wqndfm251bgmam9hln6gi"))
               (modules '((guix build utils)))
 
               ;; Remove the pre-built object files.  Instead, build everything
@@ -247,7 +247,10 @@ without requiring the source code to be rewritten.")
               (snippet '(for-each delete-file
                                   (find-files "prebuilt" "\\.go$")))))
     (synopsis "Snapshot of what will become version 2.2 of GNU Guile")
-    (properties '((timeout . 72000)))  ; 20 hours
+    (properties '((timeout . 72000)               ;20 hours
+                  (upstream-name . "guile")
+                  (ftp-server . "alpha.gnu.org")
+                  (ftp-directory . "/gnu/guile")))
     (native-search-paths
      (list (search-path-specification
             (variable "GUILE_LOAD_PATH")