summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-03-17 18:36:02 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-03-17 18:37:37 +0100
commit50ab554bd5b8f81c1d3a52901bdfbdac143b86f4 (patch)
treea5a6e4175cac1ce6453f2aac4456bdfa7b4ae743
parent22d1cb7ffaaa513f5f2e522844256f871dcd1ec8 (diff)
downloadguix-50ab554bd5b8f81c1d3a52901bdfbdac143b86f4.tar.gz
gnu: unison: Fix manual generation.
* gnu/packages/ocaml.scm (unison)[arguments]: Fix documentation
generation.
-rw-r--r--gnu/packages/ocaml.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ec1c080607..801611beb1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -816,14 +816,10 @@ libpanel, librsvg and quartz.")
                (let ((doc (string-append (assoc-ref outputs "doc")
                                          "/share/doc/unison")))
                  (mkdir-p doc)
-                 ;; This is a workaround to prevent a build failure. Running
-                 ;; make docs somehow allows it to pass, but the generated
-                 ;; documentation is not pretty.
-                 (catch #t
-                   (lambda _
-                     (invoke "make" "docs"
-                             "TEXDIRECTIVES=\\\\draftfalse"))
-                   (lambda _ #t))
+                 ;; Remove an '\n' that prevents the doc to be generated
+                 ;; correctly with newer hevea.
+                 (substitute* "doc/local.tex"
+                   (("----SNIP----.*") "----SNIP----"))
                  ;; This file needs write-permissions, because it's
                  ;; overwritten by 'docs' during documentation generation.
                  (chmod "src/strings.ml" #o600)