summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-23 19:38:48 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-23 19:40:59 +0100
commit5d5bbd6fccc2160581740c54c614cb36a51e9126 (patch)
tree28fa229650f993f92f861fb64ef1f7bb1ec77546
parenta31a3082458a9fc74b6253097a358d3ee65cfced (diff)
downloadguix-5d5bbd6fccc2160581740c54c614cb36a51e9126.tar.gz
gnu: Add star-for-pigx.
This is a follow-up to commit f1f6e49190a11f926af3bef0d45541cabf47c742.

* gnu/packages/bioinformatics.scm (star-for-pigx): New variable.
(pigx-rnaseq, pigx-scrnaseq)[inputs]: Replace star with star-for-pigx.
-rw-r--r--gnu/packages/bioinformatics.scm30
1 files changed, 28 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3890bbc653..1c42e503f2 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6889,6 +6889,32 @@ sequences.")
     ;; STAR is licensed under GPLv3 or later; htslib is MIT-licensed.
     (license license:gpl3+)))
 
+(define-public star-for-pigx
+  (package
+    (inherit star)
+    (name "star")
+    (version "2.7.3a")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/alexdobin/STAR")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1hgiqw5qhs0pc1xazzihcfd92na02xyq2kb469z04y1v51kpvvjq"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  (substitute* "source/Makefile"
+                    (("/bin/rm") "rm"))
+                  ;; Remove pre-built binaries and bundled htslib sources.
+                  (delete-file-recursively "bin/MacOSX_x86_64")
+                  (delete-file-recursively "bin/Linux_x86_64")
+                  (delete-file-recursively "bin/Linux_x86_64_static")
+                  (delete-file-recursively "source/htslib")
+                  #t))))))
+
 (define-public starlong
   (package (inherit star)
     (name "starlong")
@@ -12587,7 +12613,7 @@ once.  This package provides tools to perform Drop-seq analyses.")
        ("snakemake" ,snakemake)
        ("fastqc" ,fastqc)
        ("multiqc" ,multiqc)
-       ("star" ,star)
+       ("star" ,star-for-pigx)
        ("trim-galore" ,trim-galore)
        ("htseq" ,htseq)
        ("samtools" ,samtools)
@@ -12798,7 +12824,7 @@ methylation and segmentation.")
        ("pandoc-citeproc" ,pandoc-citeproc)
        ("samtools" ,samtools)
        ("snakemake" ,snakemake)
-       ("star" ,star)
+       ("star" ,star-for-pigx)
        ("r-minimal" ,r-minimal)
        ("r-argparser" ,r-argparser)
        ("r-cowplot" ,r-cowplot)