summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-08-29 11:57:48 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-08-29 15:05:19 +0300
commit79fa5a7a1236cae00915ccaeb39e6a43fccb473b (patch)
tree7b37a9db578db7b5cf3c1f490f8a51f3a21bf30e
parentf9a1f15efc8ebcae0502f51fbd40f074290711d9 (diff)
downloadguix-79fa5a7a1236cae00915ccaeb39e6a43fccb473b.tar.gz
gnu: Add rust-remove-dir-all.
* gnu/packages/crates-io.scm (rust-remove-dir-all): New variable.
-rw-r--r--gnu/packages/crates-io.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 80f3fae513..9b43825498 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1098,6 +1098,38 @@ and @code{ptrdistance}.")
     (license (list license:asl2.0
                    license:expat))))
 
+(define-public rust-remove-dir-all
+  (package
+    (name "rust-remove-dir-all")
+    (version "0.5.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "remove_dir_all" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "0bkrlyg26mgizpiy1yb2hhpgscxcag8r5fnckqsvk25608vzm0sa"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-winapi" ,rust-winapi))
+       #:cargo-development-inputs
+       (("rust-doc-comment" ,rust-doc-comment))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-source
+           ;; The test phase expects there to be a README.md in the root directory.
+           (lambda _
+             (invoke "touch" "README.md"))))))
+    (home-page "https://github.com/XAMPPRocky/remove_dir_all.git")
+    (synopsis "Implementation of remove_dir_all for Windows")
+    (description
+     "This package provides a safe, reliable implementation of
+@code{remove_dir_all} for Windows")
+    (license (list license:asl2.0
+                   license:expat))))
+
 (define-public rust-rustc-std-workspace-core
   (package
     (name "rust-rustc-std-workspace-core")