summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-12-05 15:20:39 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-12-05 17:39:24 +0100
commit7b81e7aa8e9814c7181fd2b8655ab949d7c37984 (patch)
treeb91fdc7fc6aa755a52d38185b2275e323884d931
parent00987a22fea295e9eec8ad6ad9c9afbe8881e30b (diff)
downloadguix-7b81e7aa8e9814c7181fd2b8655ab949d7c37984.tar.gz
gnu: Add rust-shell-words-1.
* gnu/packages/crates-io.scm (rust-shell-words-1): New variable.
(rust-shell-words-0.1): Inherit from above.
-rw-r--r--gnu/packages/crates-io.scm37
1 files changed, 24 insertions, 13 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2c016715ca..92d914df0b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -26449,27 +26449,38 @@ picking compatible shaders.")
      "Escape characters that may have a special meaning in a shell.")
     (license (list license:asl2.0 license:expat))))
 
-(define-public rust-shell-words-0.1
+(define-public rust-shell-words-1
   (package
     (name "rust-shell-words")
-    (version "0.1.0")
+    (version "1.0.0")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "shell-words" version))
-        (file-name
-         (string-append name "-" version ".tar.gz"))
-        (sha256
-         (base32
-          "0jnrw3f174974fsi2hg48l0klpy24767ib28w0xcvi2ll5axxb1r"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "shell-words" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0x5hw7ch98sp6b99ihxjs5vw5dmwg4yvy4yxzr59394xr4w3kymn"))))
     (build-system cargo-build-system)
     (home-page "https://github.com/tmiasko/shell-words")
-    (synopsis
-     "Process command line according to parsing rules of UNIX shell")
+    (synopsis "Process command line according to parsing rules of UNIX shell")
     (description
-     "Process command line according to parsing rules of UNIX shell.")
+     "This package processes command line according to parsing rules of UNIX
+shell.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-shell-words-0.1
+  (package
+    (inherit rust-shell-words-1)
+    (name "rust-shell-words")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "shell-words" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0jnrw3f174974fsi2hg48l0klpy24767ib28w0xcvi2ll5axxb1r"))))))
+
 (define-public rust-shlex-0.1
   (package
     (name "rust-shlex")