summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-06 16:49:22 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-06 18:14:52 +0200
commit839415ecbcb3c614284a60d55eb4a51591153290 (patch)
treeba077e5bf1cd65c8788ba3ab1a4e0ed5b5373e51
parent2aa0bada76dc664e9e38f4206ec526fd278a6114 (diff)
downloadguix-839415ecbcb3c614284a60d55eb4a51591153290.tar.gz
gnu: Add ghc-concatenative.
* gnu/packages/haskell.scm (ghc-concatenative): New variable.
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 738c3a18c0..5a01eeceec 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -732,6 +732,28 @@ tool lex or flex for C/C++.")
      "This library provides an easy way to define command line parsers.")
     (license license:bsd-3)))
 
+(define-public ghc-concatenative
+  (package
+    (name "ghc-concatenative")
+    (version "1.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://hackage.haskell.org/package/concatenative/concatenative-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "05xwqvcdnk8bsyj698ab9jxpa1nk23pf3m7wi9mwmw0q8n99fngd"))))
+    (build-system haskell-build-system)
+    (home-page
+     "https://patch-tag.com/r/salazar/concatenative/snapshot/current/content/pretty")
+    (synopsis "Library for postfix control flow")
+    (description
+     "Concatenative gives Haskell Factor-style combinators and arrows for
+postfix notation.  For more information on stack based languages, see
+@uref{http://concatenative.org}.")
+    (license license:bsd-3)))
+
 (define-public ghc-happy
   (package
     (name "ghc-happy")