summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-03-02 14:13:17 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-03-02 17:03:02 -0500
commit8c06d6d8cedcab1c239c5cf24b4cf600e20e35b4 (patch)
tree7626baf01fc20c717834300814d7f7145bf45a29
parentf675ab4faf22d0f7ba8dec131b2e58ed3c1f34e0 (diff)
downloadguix-8c06d6d8cedcab1c239c5cf24b4cf600e20e35b4.tar.gz
gnu: python-xenon: Update to 0.7.0.
* gnu/packages/python-xyz.scm (python-xenon): Update to 0.7.0.
[arguments]: Set #:tests? to #f to disable test suite.
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2192d7802b..d6cebca99f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13866,14 +13866,14 @@ pure Python module.")
 (define-public python-xenon
   (package
     (name "python-xenon")
-    (version "0.5.4")
+    (version "0.7.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "xenon" version))
        (sha256
         (base32
-         "029cbhysg2vr5n4jz8gpg2793f8wkwnqpr1qgv6c1dn685vy31mc"))))
+         "0nv207ql2wmh9q62503np056c4vf1c1hlsi5cvv5p5kx574k6r2y"))))
     (build-system python-build-system)
     (native-inputs
      `(("python-pyyaml" ,python-pyyaml)
@@ -13882,7 +13882,8 @@ pure Python module.")
        ("python-flake8" ,python-flake8)
        ("python-tox" ,python-tox)))
     (arguments
-     `(#:phases
+     `(#:tests? #f                      ;test suite not shipped with the PyPI archive
+       #:phases
        (modify-phases %standard-phases
          (add-before 'build 'patch-test-requirements
            (lambda _