summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-09-01 14:07:18 +0200
committerMarius Bakke <marius@gnu.org>2020-09-22 18:41:56 +0200
commit8c9365047b8ae041e6230ef5a72d6cf6f27a7521 (patch)
tree7bbc17c440f853fbab81706695e92bd57fdf342f
parentb462caaf9363084250a1e2cf9075b55a95fc55f3 (diff)
downloadguix-8c9365047b8ae041e6230ef5a72d6cf6f27a7521.tar.gz
gnu: Add python-croniter.
* gnu/packages/python-xyz.scm (python-croniter): New public variable.
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e14f4c79ee..3094b07c6d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19442,6 +19442,27 @@ file-based data structures that are @code{mmap}ped into memory so that many
 processes may share the same data.")
     (license license:asl2.0)))
 
+(define-public python-croniter
+  (package
+    (name "python-croniter")
+    (version "0.3.34")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "croniter" version))
+              (sha256
+               (base32
+                "0r79cx4v2dw4hzr0annkkxxis46c8hivq61sr39z6p7lcjsbk1ki"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-dateutil" ,python-dateutil)
+       ("python-natsort" ,python-natsort)))
+    (home-page "https://github.com/kiorky/croniter")
+    (synopsis "Iterate datetime objects with cron-like syntax")
+    (description
+     "@code{croniter} provides iteration for datetime object with cron-like
+format.")
+    (license license:expat)))
+
 (define-public python-pylzma
   (package
     (name "python-pylzma")