summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-02-23 15:05:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-02-23 16:04:26 +0200
commitae17c6c31da82d98e429751642bcf7a7cca142f5 (patch)
treef6c3702e169a4cb26a8154645df30e4ce3ea9bc5
parentb76723041becf0917e8ebfdacd0452eefd0a2730 (diff)
downloadguix-ae17c6c31da82d98e429751642bcf7a7cca142f5.tar.gz
gnu: Add ruby-mini-mime.
* gnu/packages/ruby.scm (ruby-mini-mime): New variable.
-rw-r--r--gnu/packages/ruby.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index fb0396dc52..d374e40b1c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8823,6 +8823,23 @@ definitions.")
     (home-page "https://github.com/mime-types/ruby-mime-types")
     (license license:expat)))
 
+(define-public ruby-mini-mime
+  (package
+    (name "ruby-mini-mime")
+    (version "1.0.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (rubygems-uri "mini_mime" version))
+        (sha256
+         (base32
+          "1axm0rxyx3ss93wbmfkm78a6x03l8y4qy60rhkkiq0aza0vwq3ha"))))
+    (build-system ruby-build-system)
+    (synopsis "Lightweight mime type lookup toy")
+    (description "This package provides a lightweight mime type lookup toy.")
+    (home-page "https://github.com/discourse/mini_mime")
+    (license license:expat)))
+
 (define-public ruby-fivemat
   (package
     (name "ruby-fivemat")