summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@cray.com>2018-07-31 11:32:57 -0500
committerEric Bavier <bavier@member.fsf.org>2018-09-05 08:10:37 -0500
commitc15be1280e103c781f8c57bb621e92124e8e2cc5 (patch)
tree74941dc7204ff790011303aafb985bd9dcd6b2f9
parenta3a99e27bb727b0407da13955ef47566a1919629 (diff)
downloadguix-c15be1280e103c781f8c57bb621e92124e8e2cc5.tar.gz
petsc: Upgrade to 3.9.3.
* gnu/packages/maths.scm (petsc): Upgrade to 3.9.3.
[arguments]: Remove unnecessary configure flags.
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ba39531bdb..ef20f239e5 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1580,7 +1580,7 @@ September 2004}")
 (define-public petsc
   (package
     (name "petsc")
-    (version "3.8.0")
+    (version "3.9.3")
     (source
      (origin
       (method url-fetch)
@@ -1588,9 +1588,9 @@ September 2004}")
       (uri (string-append "http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/"
                           "petsc-lite-" version ".tar.gz"))
       (sha256
-       (base32 "1lajbk3c29hnh83v6cbmm3a8wv6bdykh0p70kwrr4vrnizalk88s"))))
+       (base32 "1fwkbwv4g7zf2lc8fw865xd0bl9anb6jaczfis5dff7h449gwa48"))))
     (outputs '("out"                    ;libraries and headers
-               "examples"))             ;~24MiB of examples
+               "examples"))             ;~30MiB of examples
     (build-system gnu-build-system)
     (native-inputs
      `(("python" ,python-2)))
@@ -1607,11 +1607,7 @@ September 2004}")
        #:configure-flags
        `("--with-mpi=0"
          "--with-openmp=1"
-         "--with-superlu=1"
-         ,(string-append "--with-superlu-include="
-                         (assoc-ref %build-inputs "superlu") "/include")
-         ,(string-append "--with-superlu-lib="
-                         (assoc-ref %build-inputs "superlu") "/lib/libsuperlu.a"))
+         "--with-superlu=1")
        #:make-flags
        ;; Honor (parallel-job-count) for build.  Do not use --with-make-np,
        ;; whose value is dumped to $out/lib/petsc/conf/petscvariables.