summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-22 23:52:43 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-06-09 20:01:08 +0200
commitcfd15d96e612d0017da2f8e515da7af1ebd65231 (patch)
tree256249863166cf8cfca01d3eef93dce44265224f
parent221c514451917caa98060cdb285454bacfc25014 (diff)
downloadguix-cfd15d96e612d0017da2f8e515da7af1ebd65231.tar.gz
gnu: Add libpepadapter.
* gnu/packages/pep.scm (libpepadapter): New variable.
-rw-r--r--gnu/packages/pep.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/pep.scm b/gnu/packages/pep.scm
index d7121d6dd6..27993d4f1b 100644
--- a/gnu/packages/pep.scm
+++ b/gnu/packages/pep.scm
@@ -153,3 +153,44 @@ messages")
 privacy).")
     (license ;; code: GPL 3, docs: CC-BY-SA
      (list license:gpl3 license:cc-by-sa3.0))))
+
+(define-public libpepadapter
+  (package
+    (name "libpepadapter")
+    (version "2.0.2")
+    (source
+     (origin
+       (method hg-fetch)
+       (uri (hg-reference
+             (url "https://pep.foundation/dev/repos/libpEpAdapter")
+             (changeset "e8fe371c870a"))) ;; r168
+       (file-name (string-append name "-" version "-checkout"))
+       (sha256
+        (base32 "1mlpavjbnmslvmr5jxcvpjgb2x40nhmxjb10hza3kn4qzj0k1pjz"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:test-target "test"
+       #:tests? #f ;; building the tests fails
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           ;; libpEpAdapter does not use autotools and configure,
+           ;; but a local.conf. We need to tweak the values there.
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out"))
+                   (engine (assoc-ref inputs "pep-engine")))
+               (with-output-to-file "local.conf"
+                 (lambda _ ;()
+                   (format #t "
+PREFIX=~a
+ENGINE_LIB_PATH=~a/lib
+ENGINE_INC_PATH=~a/include
+" out engine engine))))
+             #t)))))
+    (inputs
+     `(("pep-engine" ,pep-engine)))
+    (home-page "https://pep.foundation/")
+    (synopsis "Library for building p≡p adapters")
+    (description "This C++ library provides common structures used in p≡p
+(pretty Easy privacy) adapters.")
+    (license license:bsd-3)))