summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-03-07 12:35:32 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-03-07 12:37:14 +0100
commitece22a25b6d94b99748fcfc3dbdb492f9d99ea12 (patch)
tree4783be24ca373e7890beb3327ae90ffb7c23e304
parent0bc557fd70895219f08fe0fc6d5b28190a837605 (diff)
downloadguix-ece22a25b6d94b99748fcfc3dbdb492f9d99ea12.tar.gz
gnu: fmt: Switch back to url-fetch.
* gnu/packages/pretty-print.scm (fmt)[source]: Use url-fetch instead of
  git-fetch since upstream uploads releases.  Both approaches produce the
  same package, but git-fetch requires more bandwidth.
-rw-r--r--gnu/packages/pretty-print.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index c5012b3619..18e557611e 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -169,14 +169,12 @@ different programming languages.")
     (name "fmt")
     (version "6.1.2")
     (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/fmtlib/fmt")
-                    (commit version)))
-              (file-name (git-file-name name version))
+              (method url-fetch)
+              (uri (string-append "https://github.com/fmtlib/fmt/releases/download/"
+                                  version "/fmt-" version ".zip"))
               (sha256
                (base32
-                "1ngb2fd7c2jnxi3x5kjgxmpixmyc737f77vibij43dl77ybiaihi"))))
+                "1s1hxaby5byb07rgmrk4a0q11fxhz7b42khch7sp2qx974y0yrb3"))))
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))