summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-13 09:23:38 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-13 13:52:15 -0500
commitf8bde42f24ed0063fbb3b3e5decb57fcb3d903f6 (patch)
tree258bcf2b7ec7744986bc4bc6eb583ce722085399
parent994fad660c8e8dc318878d338eca33de3e98bae8 (diff)
downloadguix-f8bde42f24ed0063fbb3b3e5decb57fcb3d903f6.tar.gz
gnu: Add Data-Page.
* gnu/packages/perl.scm (perl-data-page): New variable.
-rw-r--r--gnu/packages/perl.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index c2c07569af..8e293c05bf 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -763,6 +763,31 @@ indentation and newlines plus sub deparsing.")
      "Data::OptList provides a simple syntax for name/value option pairs.")
     (license (package-license perl))))
 
+(define-public perl-data-page
+  (package
+    (name "perl-data-page")
+    (version "2.02")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/L/LB/LBROCARD/"
+                           "Data-Page-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1hvi92c4h2angryc6pngw7gbm3ysc2jfmyxk2wh9ia4vdwpbs554"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-exception" ,perl-test-exception)))
+    (propagated-inputs
+     `(("perl-class-accessor-chained" ,perl-class-accessor-chained)))
+    (home-page "http://search.cpan.org/dist/Data-Page")
+    (synopsis "Help when paging through sets of results")
+    (description "When searching through large amounts of data, it is often
+the case that a result set is returned that is larger than we want to display
+on one page.  This results in wanting to page through various pages of data.
+The maths behind this is unfortunately fiddly, hence this module.")
+    (license (package-license perl))))
+
 (define-public perl-data-tumbler
   (package
     (name "perl-data-tumbler")