summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-24 23:19:47 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-29 14:09:22 -0400
commitc8b1799fd7c8d2f08c474d6f6761f40873a0fea1 (patch)
tree8ca9d7a16ba52ee427ee04719de1e6b75fb47eeb
parent8214e70fa8da95683cccdf45c674b8be755c27db (diff)
downloadguix-c8b1799fd7c8d2f08c474d6f6761f40873a0fea1.tar.gz
Makefile.am: Remove the GUIX_FOR_BINARY_TARBALL variable.
There is no use case where the Guix package is not named 'guix'.

* Makefile.am (GUIX_FOR_BINARY_TARBALL): Remove variable and replace its uses
by 'guix'.
-rw-r--r--Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 04b4ed74ed..216f5b90af 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -730,16 +730,13 @@ AM_DISTCHECK_CONFIGURE_FLAGS =			\
   --enable-daemon				\
   ac_cv_guix_test_root="$(GUIX_TEST_ROOT)"
 
-# Name of the 'guix' package shipped in the binary tarball.
-GUIX_FOR_BINARY_TARBALL = guix
-
 # The self-contained tarball.
 guix-binary.%.tar.xz:
 	$(AM_V_GEN)GUIX_PACKAGE_PATH=					\
 	tarball=`$(top_builddir)/pre-inst-env guix pack -C xz		\
 	  --fallback							\
 	  -s "$*" --localstatedir --profile-name=current-guix		\
-	  $(GUIX_FOR_BINARY_TARBALL)` ;					\
+	  guix` ;					\
 	cp "$$tarball" "$@.tmp" ; mv "$@.tmp" "$@"
 
 
@@ -857,7 +854,7 @@ release: dist-with-updated-version
 	   	"`git rev-parse HEAD`" "$(PACKAGE_VERSION)"
 	git add $(top_srcdir)/gnu/packages/package-management.scm
 	git commit -m "gnu: guix: Update to $(PACKAGE_VERSION)."
-	$(top_builddir)/pre-inst-env guix build $(GUIX_FOR_BINARY_TARBALL)	\
+	$(top_builddir)/pre-inst-env guix build guix	\
 	      $(call system_flags,$(SUPPORTED_SYSTEMS))	\
 	      -v1 --no-grafts --fallback
 	rm -f $(BINARY_TARBALLS)