summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-27 16:38:33 +0100
committerMarius Bakke <marius@gnu.org>2022-11-27 21:19:51 +0100
commita9956536f37f6467389941aaac57b503eeeda665 (patch)
treedcaa20b5b45ee8b8b0633c6eacb6bdca4eb812b6
parent42c59c784952458e257212c6bc5a5a82645eb9a4 (diff)
downloadguix-a9956536f37f6467389941aaac57b503eeeda665.tar.gz
gnu: Add python-attrdict.
* gnu/packages/python-xyz.scm (python-attrdict): New variable.
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7fefbc5bff..87963f9f19 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19665,6 +19665,27 @@ from the header, as well as section details and data available.")
      and bit flag values.")
     (license license:expat)))
 
+(define-public python-attrdict
+  (package
+    (name "python-attrdict")
+    (version "2.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "attrdict" version))
+              (sha256
+               (base32
+                "0w3vsz64j9npxfgh83hghsh161wwkrx1fxqi1533js2wnnc0dj9m"))))
+    (build-system python-build-system)
+    ;; The package is no longer maintained and tests need some work.
+    (arguments '(#:tests? #f))
+    (propagated-inputs (list python-six))
+    (home-page "https://github.com/bcj/AttrDict")
+    (synopsis "Attribute-style access dictionaries")
+    (description
+     "This package provides mapping objects whose elements can be accessed
+both as keys and as attributes.")
+    (license license:expat)))
+
 (define-public python-attrs
   (package
     (name "python-attrs")