summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-07-14 12:39:58 +0200
committerLudovic Courtès <ludo@gnu.org>2015-07-14 12:40:35 +0200
commit1b9cf4ad2fa4149e436787fcf50e4f68a098f32a (patch)
treebaefe03987a101e39fcbc838800295034de12f24
parent7a34576206620d61a58bca3fdcc46e1cc7669e22 (diff)
downloadguix-1b9cf4ad2fa4149e436787fcf50e4f68a098f32a.tar.gz
gnu: util-linux: Use 'modify-phases'.
* gnu/packages/linux.scm (util-linux)[arguments]: Use 'modify-phases' instead
  of 'alist-cons-before'.
-rw-r--r--gnu/packages/linux.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7810335a3b..f27b8281ab 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -417,17 +417,17 @@ providing the system administrator with some help in common tasks.")
                                (string-append "--with-bashcompletiondir="
                                               (assoc-ref %outputs "out")
                                               "/etc/bash_completion.d"))
-       #:phases (alist-cons-before
-                 'check 'pre-check
-                 (lambda* (#:key inputs outputs #:allow-other-keys)
-                   (let ((out (assoc-ref outputs "out"))
-                         (net (assoc-ref inputs "net-base")))
-                     ;; Change the test to refer to the right file.
-                     (substitute* "tests/ts/misc/mcookie"
-                       (("/etc/services")
-                        (string-append net "/etc/services")))
-                     #t))
-                 %standard-phases)))
+       #:phases (modify-phases %standard-phases
+                  (add-before
+                   'check 'pre-check
+                   (lambda* (#:key inputs outputs #:allow-other-keys)
+                     (let ((out (assoc-ref outputs "out"))
+                           (net (assoc-ref inputs "net-base")))
+                       ;; Change the test to refer to the right file.
+                       (substitute* "tests/ts/misc/mcookie"
+                         (("/etc/services")
+                          (string-append net "/etc/services")))
+                       #t))))))
     (inputs `(("zlib" ,zlib)
               ("ncurses" ,ncurses)))
     (native-inputs