summary refs log tree commit diff
diff options
context:
space:
mode:
authorVicente Vera Parra <vicentemvp@gmail.com>2015-09-15 14:20:13 -0300
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-21 10:48:26 +0200
commit213656b95b3067c141e8d3fe458463326f2e7c6c (patch)
treeed0d0d6e014271925c2570827a93ff7cce498064
parentea3a80957aa7b38cb8cf9c2a9cb104e724292384 (diff)
downloadguix-213656b95b3067c141e8d3fe458463326f2e7c6c.tar.gz
gnu: Add r-knitr.
* gnu/packages/statistics.scm (r-knitr): New variable.
-rw-r--r--gnu/packages/statistics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 9c0c9fd11e..c3d98a6ca1 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -681,3 +681,32 @@ syntax that can be converted to XHTML or other formats.")
      "This package implements the libyaml YAML 1.1 parser and
 emitter (http://pyyaml.org/wiki/LibYAML) for R.")
     (license license:bsd-3)))
+
+(define-public r-knitr
+  (package
+    (name "r-knitr")
+    (version "1.11")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "knitr" version))
+              (sha256
+               (base32
+                "1ikjla0hnpjfkdbydqhhqypc0aiizbi4nyn8c694sdk9ca4jasdd"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-evaluate" ,r-evaluate)
+       ("r-digest" ,r-digest)
+       ("r-formatr" ,r-formatr)
+       ("r-highr" ,r-highr)
+       ("r-markdown" ,r-markdown)
+       ("r-stringr" ,r-stringr)
+       ("r-yaml" ,r-yaml)))
+    (home-page "http://yihui.name/knitr/")
+    (synopsis "General-purpose package for dynamic report generation in R")
+    (description
+     "This package provides a general-purpose tool for dynamic report
+generation in R using Literate Programming techniques.")
+    ;; The code is released under any version of the GPL.  As it is used by
+    ;; r-markdown which is available under GPLv2 only, we have chosen GPLv2+
+    ;; here.
+    (license license:gpl2+)))