summary refs log tree commit diff
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2014-09-29 18:52:57 +0300
committerLudovic Courtès <ludo@gnu.org>2014-09-30 13:38:01 +0200
commiteff5f452b0499036276e119980fd5d30e2832b38 (patch)
treef0384a034cedbbb6054628bf14bd77b162010e98
parent6d7328b2f19d2a13d18e34cc875f6c8b5218ac1d (diff)
downloadguix-eff5f452b0499036276e119980fd5d30e2832b38.tar.gz
gnu: Move flashrom and avrdude to (gnu packages flashing-tools).
* gnu/packages/admin.scm (flashrom): Move this and...
* gnu/packages/avrdude.scm (avrdude): ... this to...
* gnu/packages/flashing-tools.scm: ... this. New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Adjust accordingly.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu-system.am2
-rw-r--r--gnu/packages/admin.scm44
-rw-r--r--gnu/packages/flashing-tools.scm (renamed from gnu/packages/avrdude.scm)52
3 files changed, 51 insertions, 47 deletions
diff --git a/gnu-system.am b/gnu-system.am
index b2ad29ae30..642751c9ea 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -38,7 +38,6 @@ GNU_SYSTEM_MODULES =				\
   gnu/packages/autogen.scm			\
   gnu/packages/autotools.scm			\
   gnu/packages/avahi.scm			\
-  gnu/packages/avrdude.scm			\
   gnu/packages/backup.scm			\
   gnu/packages/base.scm				\
   gnu/packages/bash.scm				\
@@ -82,6 +81,7 @@ GNU_SYSTEM_MODULES =				\
   gnu/packages/enchant.scm			\
   gnu/packages/file.scm				\
   gnu/packages/fish.scm				\
+  gnu/packages/flashing-tools.scm		\
   gnu/packages/flex.scm				\
   gnu/packages/fltk.scm				\
   gnu/packages/fonts.scm			\
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index f6ff32c8a2..a5b84af61a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -794,50 +794,6 @@ status for the CPU sockets, expansion slots (e.g. AGP, PCI, ISA) and memory
 module slots, and the list of I/O ports (e.g. serial, parallel, USB).")
     (license gpl2+)))
 
-(define-public flashrom
-  (package
-    (name "flashrom")
-    (version "0.9.7")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "http://download.flashrom.org/releases/flashrom-"
-                    version ".tar.bz2"))
-              (sha256
-               (base32
-                "1s9pc4yls2s1gcg2ar4q75nym2z5v6lxq36bl6lq26br00nj2mas"))
-              (patches (list (search-patch "flashrom-use-libftdi1.patch")))))
-    (build-system gnu-build-system)
-    (inputs `(("dmidecode" ,dmidecode)
-              ("pciutils" ,pciutils)
-              ("libusb" ,libusb)
-              ("libftdi" ,libftdi)))
-    (native-inputs `(("pkg-config" ,pkg-config)))
-    (arguments
-     '(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
-       #:tests? #f   ; no 'check' target
-       #:phases
-       (alist-delete
-        'configure
-        (alist-cons-before
-         'build 'patch-exec-paths
-         (lambda* (#:key inputs #:allow-other-keys)
-           (substitute* "dmi.c"
-             (("\"dmidecode\"")
-              (format #f "~S"
-                      (string-append (assoc-ref inputs "dmidecode")
-                                     "/sbin/dmidecode")))))
-         %standard-phases))))
-    (home-page "http://flashrom.org/")
-    (synopsis "Identify, read, write, erase, and verify ROM/flash chips")
-    (description
-     "flashrom is a utility for identifying, reading, writing,
-verifying and erasing flash chips.  It is designed to flash
-BIOS/EFI/coreboot/firmware/optionROM images on mainboards,
-network/graphics/storage controller cards, and various other
-programmer devices.")
-    (license gpl2)))
-
 (define-public acpica
   (package
     (name "acpica")
diff --git a/gnu/packages/avrdude.scm b/gnu/packages/flashing-tools.scm
index 28456045e0..d2f1b469b6 100644
--- a/gnu/packages/avrdude.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -1,4 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -16,7 +17,7 @@
 ;;; You should have received a copy of the GNU General Public License
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
-(define-module (gnu packages avrdude)
+(define-module (gnu packages flashing-tools)
   #:use-module (guix licenses)
   #:use-module (guix download)
   #:use-module (guix packages)
@@ -25,8 +26,55 @@
   #:use-module (gnu packages bison)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages elf)
+  #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages libusb)
-  #:use-module (gnu packages libftdi))
+  #:use-module (gnu packages libftdi)
+  #:use-module (gnu packages pciutils)
+  #:use-module (gnu packages admin))
+
+(define-public flashrom
+  (package
+    (name "flashrom")
+    (version "0.9.7")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://download.flashrom.org/releases/flashrom-"
+                    version ".tar.bz2"))
+              (sha256
+               (base32
+                "1s9pc4yls2s1gcg2ar4q75nym2z5v6lxq36bl6lq26br00nj2mas"))
+              (patches (list (search-patch "flashrom-use-libftdi1.patch")))))
+    (build-system gnu-build-system)
+    (inputs `(("dmidecode" ,dmidecode)
+              ("pciutils" ,pciutils)
+              ("libusb" ,libusb)
+              ("libftdi" ,libftdi)))
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (arguments
+     '(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
+       #:tests? #f   ; no 'check' target
+       #:phases
+       (alist-delete
+        'configure
+        (alist-cons-before
+         'build 'patch-exec-paths
+         (lambda* (#:key inputs #:allow-other-keys)
+           (substitute* "dmi.c"
+             (("\"dmidecode\"")
+              (format #f "~S"
+                      (string-append (assoc-ref inputs "dmidecode")
+                                     "/sbin/dmidecode")))))
+         %standard-phases))))
+    (home-page "http://flashrom.org/")
+    (synopsis "Identify, read, write, erase, and verify ROM/flash chips")
+    (description
+     "flashrom is a utility for identifying, reading, writing,
+verifying and erasing flash chips.  It is designed to flash
+BIOS/EFI/coreboot/firmware/optionROM images on mainboards,
+network/graphics/storage controller cards, and various other
+programmer devices.")
+    (license gpl2)))
 
 (define-public avrdude
   (package