summary refs log tree commit diff
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-02-11 03:32:51 +0100
committerCyril Roelandt <tipecaml@gmail.com>2013-02-11 22:23:29 +0100
commitb1426f17859173fedc40f14c9e2d40c64a0f469b (patch)
tree6cf55885a94e854223ef873d6190d04fb8c30f14
parent95b6c70f6b3da28c1e1e869308614d317e621269 (diff)
downloadguix-b1426f17859173fedc40f14c9e2d40c64a0f469b.tar.gz
gnu: Add tmux. licenses: add ISC.
* gnu/packages/tmux.scm: New file.
* Makefile.am (MODULES): Use it.
* guix/licenses.scm: add ISC.
-rw-r--r--Makefile.am1
-rw-r--r--gnu/packages/tmux.scm51
-rw-r--r--guix/licenses.scm6
3 files changed, 58 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f9b64e7775..3c47dd01b4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -143,6 +143,7 @@ MODULES =					\
   gnu/packages/texinfo.scm			\
   gnu/packages/texlive.scm			\
   gnu/packages/time.scm				\
+  gnu/packages/tmux.scm 			\
   gnu/packages/tor.scm				\
   gnu/packages/wget.scm				\
   gnu/packages/which.scm			\
diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
new file mode 100644
index 0000000000..bbfc6cf9bf
--- /dev/null
+++ b/gnu/packages/tmux.scm
@@ -0,0 +1,51 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages tmux)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages libevent)
+  #:use-module (gnu packages ncurses))
+
+(define-public tmux
+  (package
+    (name "tmux")
+    (version "1.7")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                    "mirror://sourceforge/tmux/tmux/tmux-"
+                    version "/tmux-" version ".tar.gz"))
+             (sha256
+              (base32
+               "0ywy1x2g905hmhkdz418ik42lcvnhnwr8fv63rcqczfg27d6nd38"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("libevent" ,libevent)
+       ("ncurses" ,ncurses)))
+    (home-page "http://tmux.sourceforge.net/")
+    (synopsis "A terminal multiplexer")
+    (description
+     "tmux is a terminal multiplexer: it enables a number of terminals (or
+windows), each running a separate program, to be created, accessed, and
+controlled from a single screen. tmux may be detached from a screen and
+continue running in the background, then later reattached.")
+    (license isc)))
diff --git a/guix/licenses.scm b/guix/licenses.scm
index 1b149b5282..4e4aee2036 100644
--- a/guix/licenses.scm
+++ b/guix/licenses.scm
@@ -30,6 +30,7 @@
             expat
             freetype
             gpl1 gpl1+ gpl2 gpl2+ gpl3 gpl3+
+            isc
             ijg
             ibmpl1.0
             lgpl2.0 lgpl2.0+ lgpl2.1 lgpl2.1+ lgpl3 lgpl3+
@@ -149,6 +150,11 @@ which may be a file:// URI pointing the package's tree."
            "https://www.gnu.org/licenses/gpl.html"
            "https://www.gnu.org/licenses/license-list#GNUGPLv3"))
 
+(define isc
+  (license "ISC"
+           "http://directory.fsf.org/wiki/License:ISC"
+           "https://www.gnu.org/licenses/license-list.html#ISC"))
+
 (define ijg
   (license "IJG"
            "http://directory.fsf.org/wiki/License:JPEG"