summary refs log tree commit diff
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2016-07-06 18:58:17 -0500
committerEfraim Flashner <efraim@flashner.co.il>2016-07-10 07:11:08 +0300
commit0e74bb5bd6fe9e1839484edaaec98dbcefbdfdc7 (patch)
tree538d2dfc31a1d5ea75bbaaf585df8b6c89519c11
parent6cf83e3f83a9373d0da2ea3b29597c370133c9ff (diff)
downloadguix-0e74bb5bd6fe9e1839484edaaec98dbcefbdfdc7.tar.gz
gnu: Add gnome-mpv.
* gnu/packages/video.scm (gnome-mpv): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/video.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ae1813db1d..6888e36711 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -33,6 +33,7 @@
   #:use-module (guix git-download)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system python)
   #:use-module (guix build-system waf)
   #:use-module (gnu packages)
@@ -829,6 +830,34 @@ fork of mplayer2 and MPlayer.  It shares some features with the former
 projects while introducing many more.")
     (license license:gpl2+)))
 
+(define-public gnome-mpv
+  (package
+    (name "gnome-mpv")
+    (version "0.9")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/gnome-mpv/gnome-mpv/releases"
+                           "/download/v" version "/gnome-mpv-" version
+                           ".tar.xz"))
+       (sha256
+        (base32
+         "06pgxl6f3kkgxv8nlmyl7gy3pg55sqf8vgr8m6426mlpm4p3qdn0"))))
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("gtk+" ,gtk+)
+       ("libepoxy" ,libepoxy)
+       ("mpv" ,mpv)))
+    (build-system glib-or-gtk-build-system)
+    (home-page "https://github.com/gnome-mpv/gnome-mpv")
+    (synopsis "GTK+ frontend for the mpv media player")
+    (description "GNOME MPV is a simple GTK+ frontend for the mpv media player.
+GNOME MPV interacts with mpv via the client API exported by libmpv, allowing
+access to mpv's powerful playback capabilities.")
+    (license license:gpl3+)))
+
 (define-public libvpx
   (package
     (name "libvpx")