summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-02 01:01:58 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-02 01:01:58 +0100
commit52b8e5fc30f42914c1dadeca4243a5b55467be48 (patch)
tree8feee88c976e6768222bedb2fa028c856e9cbc5d
parent46866fadee576d3c1dfa4b3d3ab819bfae3fdf8b (diff)
downloadguix-52b8e5fc30f42914c1dadeca4243a5b55467be48.tar.gz
distro: sed: Patch references to /bin/sh in the test suite.
* distro/packages/base.scm (sed): Add `patch-test-suite' phase.
-rw-r--r--distro/packages/base.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/distro/packages/base.scm b/distro/packages/base.scm
index 158a7d2f73..ad9561b5f4 100644
--- a/distro/packages/base.scm
+++ b/distro/packages/base.scm
@@ -97,6 +97,17 @@ lines.")
               "13wlsb4sf5d5a82xjhxqmdvrrn36rmw5f0pl9qyb9zkvldnb7hra"))))
    (build-system gnu-build-system)
    (synopsis "GNU sed, a batch stream editor")
+   (arguments
+    `(#:phases (alist-cons-before
+                'patch-source-shebangs 'patch-test-suite
+                (lambda* (#:key inputs #:allow-other-keys)
+                  (let ((bash (assoc-ref inputs "bash")))
+                    (patch-makefile-SHELL "testsuite/Makefile.tests")
+                    (substitute* '("testsuite/bsd.sh"
+                                   "testsuite/bug-regex9.c")
+                      (("/bin/sh")
+                       (string-append bash "/bin/bash")))))
+                %standard-phases)))
    (description
     "Sed (stream editor) isn't really a true text editor or text processor.
 Instead, it is used to filter text, i.e., it takes text input and performs