summary refs log tree commit diff
diff options
context:
space:
mode:
authorhumanitiesNerd <catonano@gmail.com>2016-05-29 10:23:00 +0200
committerAlex Kost <alezost@gmail.com>2016-05-30 13:09:43 +0300
commit32abfcf4ee6a42d0678ba40a4fcc97ca041cc382 (patch)
tree377d85693136abeaead47cbce7668d16f6a5b7f5
parentad6c4bc48a3fcb6195e4382df4036e2efae2b5c0 (diff)
downloadguix-32abfcf4ee6a42d0678ba40a4fcc97ca041cc382.tar.gz
gnu: Add emacs-pkg-info.
* gnu/packages/emacs.scm (emacs-pkg-info): New variable.

Signed-off-by: Alex Kost <alezost@gmail.com>
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 676e6232f4..847b609a4f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1729,3 +1729,24 @@ stack, i.e. elements can be added to the front or back of the queue, and can
 be removed from the front.  This type of data structure is sometimes called an
 \"output-restricted deque\".")
     (license license:gpl3+)))
+
+(define-public emacs-pkg-info
+  (package
+    (name "emacs-pkg-info")
+    (version "0.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/lunaryorn/pkg-info.el/archive/"
+                    version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1gy1jks5mmm02gg1c8gcyr4f8a9s5ggzhk56gv33b9mzjqzi5rd5"))))
+    (build-system emacs-build-system)
+    (propagated-inputs `(("emacs-epl" ,emacs-epl)))
+    (home-page "https://github.com/lunaryorn/pkg-info.el")
+    (synopsis "Information about Emacs packages")
+    (description
+     "This library extracts information from the installed Emacs packages.")
+    (license license:gpl3+)))