summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-26 05:00:51 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-29 00:23:27 +0100
commit83c9288230b6a16d51b8b286f9aa0aa8b4c34b4a (patch)
tree29197b19f6093521b7c2ce0e45f51a0a4a76eba2
parentde2bc8d6da0ba4e74ed083af66a22cf96f74e67f (diff)
downloadguix-83c9288230b6a16d51b8b286f9aa0aa8b4c34b4a.tar.gz
gnu: simplescreenrecorder: Update to 0.3.9.
* gnu/packages/video.scm (simplescreenrecorder): Update to 0.3.9.
[build-system]: Switch to cmake-build-system.
[inputs]: Replace qt-4 with qt.
[arguments]: Build WITH_QT5.  Disable non-existent test suite.
-rw-r--r--gnu/packages/video.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0524b33416..2d48c5aaf7 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2007,7 +2007,7 @@ making @dfn{screencasts}.")
 (define-public simplescreenrecorder
   (package
     (name "simplescreenrecorder")
-    (version "0.3.8")
+    (version "0.3.9")
     (source
      (origin
        (method url-fetch)
@@ -2016,8 +2016,8 @@ making @dfn{screencasts}.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "0v8w35n8w772s08w7k0icynqdsdakbrcanbgx6j847bfqfsg21gg"))))
-    (build-system gnu-build-system)
+         "1gnf9wbiq2fcbqcn1a5nfmp8r0nxrrlgh2wly2mfkkwymynhx0pk"))))
+    (build-system cmake-build-system)
     ;; Although libx11, libxfixes, libxext are listed as build dependencies in
     ;; README.md, the program builds and functions properly without them.
     ;; As a result, they are omitted. Please add them back if problems appear.
@@ -2028,8 +2028,12 @@ making @dfn{screencasts}.")
        ("jack" ,jack-1)
        ("libxi" ,libxi)
        ("pulseaudio" ,pulseaudio)
-       ("qt" ,qt-4))) ; README.md: using Qt 5 causes some stability issues
+       ("qt" ,qt)))
     (native-inputs `(("pkg-config" ,pkg-config)))
+    (arguments
+     `(#:configure-flags
+       (list "-DWITH_QT5=TRUE")
+       #:tests? #f))                    ; no test suite
     ;; Using HTTPS causes part of the page to be displayed improperly.
     (home-page "http://www.maartenbaert.be/simplescreenrecorder/")
     (synopsis "Screen recorder")