summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-02 13:04:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-02 13:05:42 +0200
commitc661f25a944133dbdadcd185fd7cd4762419d254 (patch)
treed3883e0cf03892cc10fd8861f94d8388999704da
parentf764868d374254473d0ffd3b104e560ea91a020e (diff)
downloadguix-c661f25a944133dbdadcd185fd7cd4762419d254.tar.gz
gnu: ocaml@4.01: Enable building on aarch64-linux.
This reverts 454e7132d6fffb5c9a5ce086ffd1b687416feb83.

* gnu/packages/ocaml.scm (ocaml@4.01)[supported-systems]: Remove field.
[arguments]: When building on aarch64-linux, replace the custom
'configure script.
-rw-r--r--gnu/packages/ocaml.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c25f7c0858..11389440dc 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -249,6 +249,17 @@ functional, imperative and object-oriented styles of programming.")
              (lambda _
                ;; Specifying '-j' at all causes the build to fail.
                (zero? (system* "make" "world.opt"))))
+           ,@(if (string=? "aarch64-linux" (%current-system))
+               ;; Custom configure script doesn't recongnize aarch64.
+               '((replace 'configure
+                  (lambda* (#:key outputs #:allow-other-keys)
+                    (let* ((out (assoc-ref outputs "out"))
+                           (mandir (string-append out "/share/man")))
+                      (invoke "./configure"
+                              "--prefix" out
+                              "--mandir" mandir
+                              "-host" "armv8l-unknown-linux-gnu")))))
+               '())
            (replace 'check
              (lambda _
                (with-directory-excursion "testsuite"
@@ -256,8 +267,7 @@ functional, imperative and object-oriented styles of programming.")
                          "make"
                          "all"
                          (string-append
-                          "TOPDIR=" (getcwd) "/.."))))))))))
-    (supported-systems (delete "aarch64-linux" %supported-systems))))
+                          "TOPDIR=" (getcwd) "/.."))))))))))))
 
 (define-public ocaml-4.07
   (package