summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-07-21 23:14:39 +0200
committerLudovic Courtès <ludo@gnu.org>2015-07-21 23:16:36 +0200
commit5d09263bfd5fe573ae74a922ceacb11ca5653c7b (patch)
tree1b74599a80436329fbeb0f5619658a30f8f211b9
parente348eaaf318646e259a5e6803133ad5b296febc1 (diff)
downloadguix-5d09263bfd5fe573ae74a922ceacb11ca5653c7b.tar.gz
gnu: guix: Update to 0.8.3.
* gnu/packages/package-management.scm (guix-0.8.2): Rename to...
  (guix-0.8.3): ... this.  Adjust users.  Add 'disable-container-tests'
  phase.
  (guix): Set to GUIX-0.8.3.
-rw-r--r--gnu/packages/package-management.scm25
1 files changed, 18 insertions, 7 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index b8efab8ffb..bb2d2a5459 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -52,17 +52,17 @@
                      arch "-linux"
                      "/20131110/guile-2.0.9.tar.xz")))
 
-(define-public guix-0.8.2
+(define-public guix-0.8.3
   (package
     (name "guix")
-    (version "0.8.2")
+    (version "0.8.3")
     (source (origin
              (method url-fetch)
              (uri (string-append "ftp://alpha.gnu.org/gnu/guix/guix-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "1a5gnkh17w7fgi5zy63ph64iqdvarkdqypkwgw2iifpqa6jq04zz"))))
+               "14n0nkj0ckhdwhghx1pml99hbjr1xdkn8x145j0xp1357vqlisnz"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags (list
@@ -100,6 +100,17 @@
                      (copy "armhf")
                      #t))
                   (add-after
+                   'unpack 'disable-container-tests
+                   ;; XXX FIXME: These tests fail within the build container.
+                   (lambda _
+                     (substitute* "tests/syscalls.scm"
+                       (("^\\(test-assert \"(clone|setns|pivot-root)\"" all)
+                        (string-append "(test-skip 1)\n" all)))
+                     (substitute* "tests/containers.scm"
+                       (("^\\(test-assert" all)
+                        (string-append "(test-skip 1)\n" all)))
+                     #t))
+                  (add-after
                    'install 'wrap-program
                    (lambda* (#:key inputs outputs #:allow-other-keys)
                      ;; Make sure the 'guix' command finds GnuTLS and
@@ -166,7 +177,7 @@ the Nix package manager.")
   ;; Note: use a short commit id; when using the long one, the limit on socket
   ;; file names is exceeded while running the tests.
   (let ((commit "72cd8ec"))
-    (package (inherit guix-0.8.2)
+    (package (inherit guix-0.8.3)
       (version (string-append "0.8.2." commit))
       (source (origin
                 (method git-fetch)
@@ -178,7 +189,7 @@ the Nix package manager.")
                   "0mfn3y4kihv6xn3a05zafdswy6v8bncddrn4n4qciinplnyg20wa"))
                 (file-name (string-append "guix-" version "-checkout"))))
       (arguments
-       (substitute-keyword-arguments (package-arguments guix-0.8.2)
+       (substitute-keyword-arguments (package-arguments guix-0.8.3)
          ((#:phases phases)
           `(modify-phases ,phases
              (add-after
@@ -208,9 +219,9 @@ the Nix package manager.")
          ("texinfo" ,texinfo)
          ("graphviz" ,graphviz)
          ("help2man" ,help2man)
-         ,@(package-native-inputs guix-0.8.2))))))
+         ,@(package-native-inputs guix-0.8.3))))))
 
-(define-public guix guix-devel)
+(define-public guix guix-0.8.3)
 
 (define-public nix
   (package