summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-11-04 09:16:04 +0200
committerEfraim Flashner <efraim@flashner.co.il>2015-11-04 09:16:04 +0200
commit7e096dd290aa192f4ed8d96ee4712f8deefe9923 (patch)
tree033c9eca37c7ee072fb69b785414afabb07b3c91
parentae3d99e9da4531a49f1163b31de467c549c01848 (diff)
downloadguix-7e096dd290aa192f4ed8d96ee4712f8deefe9923.tar.gz
gnu: ucommon: Update to 6.6.2.
* gnu/packages/telephony.scm (ucommon): Update to 6.6.2.
  [license]: Change to gpl3+.
-rw-r--r--gnu/packages/telephony.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 6f90843a18..2cb070dc5f 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
+;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -59,20 +60,20 @@ reimplementation.")
 (define-public ucommon
   (package
    (name "ucommon")
-   (version "6.6.0")
+   (version "6.6.2")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/commoncpp/" name "-"
                    version ".tar.gz"))
             (sha256 (base32
-                     "09y6rs51wl2851xp5zlxlqqb97xfi39v0yna3njb62swwr1n1ky1"))))
+                     "16haqzq97axiyhgpca95rhr5y5s7fl8b65if5vil7v4lcqxp3hqn"))))
    (build-system gnu-build-system)
    (synopsis "Common C++ framework for threaded applications")
    (description "GNU uCommon C++ is meant as a very light-weight C++ library
 to facilitate using C++ design patterns even for very deeply embedded
 applications, such as for systems using uclibc along with posix threading
 support.")
-   (license gpl2+) ; plus runtime exception
+   (license gpl3+)
    (home-page "http://www.gnu.org/software/commoncpp")))
 
 (define-public ccrtp