summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-10-07 21:08:38 -0400
committerLeo Famulari <leo@famulari.name>2018-10-07 21:19:07 -0400
commit0a3e9bf62171b051656f24b81094064b479ebf2e (patch)
tree6cd3aeb2995b59bca2e8998e7f27426714440401
parente8bd1946ec1df9f52f87292172af5b4e4a4e0023 (diff)
downloadguix-0a3e9bf62171b051656f24b81094064b479ebf2e.tar.gz
gnu: Go 1.9: Fix test failure with binutils >= 2.31.
* gnu/packages/golang.scm (go-1.9)[arguments]: Add a substitution to the
prebuild phase.
-rw-r--r--gnu/packages/golang.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7f26fbdab6..1ce06a47b6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -273,6 +273,15 @@ in the style of communicating sequential processes (@dfn{CSP}).")
                     (string-append
                      "\"-Wl,-rpath=" gcclib "\", \"-lgcc_s\", ")))
 
+                 ;; XXX Commit 65fa2b615b72c1fa61a7 in the Go repo.  We do this
+                 ;; without a patch because ((guix packages) patch-and-repack)
+                 ;; resets file mtimes, and parts of Go's test suite rely on
+                 ;; those timestamps.
+                 ;; <https://github.com/golang/go/issues/26369>
+                 (substitute* "cmd/internal/objfile/elf.go"
+                   (("PT_LOAD")
+                     "PT_LOAD && p.Flags&elf.PF_X != 0"))
+
                  ;; Disable failing tests: these tests attempt to access
                  ;; commands or network resources which are neither available
                  ;; nor necessary for the build to succeed.