summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-04-29 22:34:52 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-30 10:32:11 +0200
commit1f1a00502e2e70283fdf9a03567db74eecad7a02 (patch)
tree947f5a8147a1234fe23189824f880c3c0dfdaa16
parentf420d639df54bd8d47e84e1391e1a0e4584762a7 (diff)
downloadguix-1f1a00502e2e70283fdf9a03567db74eecad7a02.tar.gz
build: 'assert-no-store-file-names' no longer depends on ChangeLog.
This reverts commit dfd248648f59af374bf2c74403f0e561464f6afe,
which effectively disabled 'ChangeLog' generation.

* Makefile.am (dist-hook): Depend on 'gen-ChangeLog', not
'$(distdir)/ChangeLog'.
(gen-ChangeLog): Remove dependency.  Use "ChangeLog.tmp" as the
temporary file name.
(assert-no-store-file-names): Remove dependency.  Exclude ChangeLog*.
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 36f3bc5c27..45807af8b8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -627,7 +627,7 @@ guix-binary.%.tar.xz:
 	cp "$$tarball" "$@.tmp" ; mv "$@.tmp" "$@"
 
 
-dist-hook: $(distdir)/ChangeLog gen-AUTHORS gen-tarball-version
+dist-hook: gen-ChangeLog gen-AUTHORS gen-tarball-version
 dist-hook: assert-no-store-file-names
 dist-hook: doc-po-update
 
@@ -641,12 +641,12 @@ $(top_srcdir)/.version:
 gen-tarball-version:
 	echo $(VERSION) > "$(distdir)/.tarball-version"
 
-gen-ChangeLog $(distdir)/ChangeLog:
+gen-ChangeLog:
 	$(AM_V_GEN)if test -d .git; then		\
 	  $(top_srcdir)/build-aux/gitlog-to-changelog	\
-	    > $(distdir)/cl-t;				\
+	    > $(distdir)/ChangeLog.tmp;			\
 	  rm -f $(distdir)/ChangeLog;			\
-	  mv $(distdir)/cl-t $(distdir)/ChangeLog;	\
+	  mv $(distdir)/ChangeLog.tmp $(distdir)/ChangeLog;	\
 	fi
 
 gen-AUTHORS:
@@ -791,13 +791,13 @@ update-NEWS: $(GOBJECTS)
 	  $(top_srcdir)/NEWS "$(GUIX_MAINTENANCE_DIRECTORY)/data"
 
 # Make sure we're not shipping a file that embeds a local /gnu/store file name.
-assert-no-store-file-names: $(distdir)/ChangeLog
+assert-no-store-file-names:
 	$(AM_V_at)if grep -r --exclude=*.texi --exclude=*.info			\
 	     --exclude=*.info-[0-9] --exclude=*.dot				\
 	     --exclude=*.eps --exclude-dir=bootstrap				\
 		 --exclude=guix-manual.pot --exclude=guix-manual.*.po		\
 	     --exclude=guix-prettify.el						\
-	     --exclude=ChangeLog						\
+	     --exclude=ChangeLog*						\
 	     -E "$(storedir)/[a-z0-9]{32}-" $(distdir) ;			\
 	then									\
 	  echo "error: store file names embedded in the distribution" >&2 ;	\