summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-26 17:40:37 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-26 18:28:42 +0200
commit22cd6a1d4f81c2e92e92d5fe5c244cd895b046c6 (patch)
tree451606de26fa38d17b05292e5edc440a92d618e3
parent5cb40adaa2e7fe2e306f25dd941ba6da6ec5e8a0 (diff)
downloadguix-22cd6a1d4f81c2e92e92d5fe5c244cd895b046c6.tar.gz
gnu: ocaml-result: Update to 1.3.
* gnu/packages/ocaml.scm (ocaml-result): Update to 1.3.
[build-system]: Use dune-build-system.
[source]: Use git-fetch.
-rw-r--r--gnu/packages/ocaml.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d710576d3f..b6df41412d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1428,21 +1428,19 @@ powerful.")
 (define-public ocaml-result
   (package
     (name "ocaml-result")
-    (version "1.2")
+    (version "1.3")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/janestreet/result"
-                                  "/archive/" version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/janestreet/result")
+                     (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1pgpfsgvhxnh0i37fkvp9j8nadns9hz9iqgabj4dr519j2gr1xvw"))))
-    (build-system ocaml-build-system)
+                "081ayblszn9pj2rqcif40x6cz2zda48vi45gy49rc2qfc4gszry3"))))
+    (build-system dune-build-system)
     (arguments
-     `(#:tests? #f
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure))))
+     `(#:test-target "."))
     (home-page "https://github.com/janestreet/result")
     (synopsis "Compatibility Result module")
     (description "Uses the new result type defined in OCaml >= 4.03 while