summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-07 13:27:48 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-07 15:37:11 +0100
commit2b30af95416f37f8e371d59f6a7dd8607aea6e2a (patch)
tree0637e4f377a608ddc69c31d2493037633ca86eb7
parent30e43e816b15caab97183362235d2c39ea18ec7f (diff)
downloadguix-2b30af95416f37f8e371d59f6a7dd8607aea6e2a.tar.gz
gnu: c-reduce: Update to 2.6.0.
* gnu/packages/debug.scm (c-reduce): Update to 2.6.0.
-rw-r--r--gnu/packages/debug.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 6b566b0097..92d635332f 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014, 2015, 2016, 2017 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -85,10 +86,11 @@ program to exhibit a bug.")
     ;; home-page pointing to a bsd-2 license.
     (license bsd-3)))
 
+;; Newer versions depend on LLVM and Clang >= 4, which have yet to be packaged.
 (define-public c-reduce
   (package
     (name "c-reduce")
-    (version "2.5.0")
+    (version "2.6.0")
     (source
      (origin
       (method url-fetch)
@@ -97,12 +99,12 @@ program to exhibit a bug.")
                            "creduce-" version ".tar.gz")))
       (sha256
        (base32
-        "1r23lhzq3dz8vi2dalxk5las8bf0av2w94hxxbs61pr73m77ik9d"))))
+        "0pf5q0n8vkdcr1wrkxn2jzxv0xkrir13bwmqfw3jpbm3dh2c3b6d"))))
     (build-system gnu-build-system)
     (inputs
      `(("astyle"          ,astyle)
-       ("llvm"            ,llvm)
-       ("clang"           ,clang)
+       ("llvm"            ,llvm-3.9.1)
+       ("clang"           ,clang-3.9.1)
        ("flex"            ,flex)
        ("indent"          ,indent)
        ("perl"            ,perl)