summary refs log tree commit diff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2017-12-04 11:17:18 -0500
committerKei Kebreau <kkebreau@posteo.net>2017-12-22 11:49:28 -0500
commit3a1f26ff75d5032f402b5bb95c579ced37492f10 (patch)
tree48164de420e13145e5d2f0220aa45cc25fe47ff2
parent0054564b857c6ce2469ea2a7d0096ec31b3f80d9 (diff)
downloadguix-3a1f26ff75d5032f402b5bb95c579ced37492f10.tar.gz
gnu: Add python-olefile.
* gnu/packages/python.scm (python-olefile, python2-olefile): New variables.
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 48e8d44ffc..d3bd2078b0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3657,6 +3657,32 @@ Python's distutils.")
 services for your Python modules and applications.")
     (license license:lgpl3+)))
 
+(define-public python-olefile
+  (package
+    (name "python-olefile")
+    (version "0.44")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/decalage2/olefile/archive/v"
+                           version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1wmxbrhyqjry2000zx0zdhqdqxhgi06nz7sbzjlh222q2zjv1gpj"))))
+    (build-system python-build-system)
+    (home-page
+     "https://www.decalage.info/python/olefileio")
+    (synopsis "Read and write Microsoft OLE2 files.")
+    (description
+     "@code{olefile} can parse, read and write Microsoft OLE2 files (Structured
+Storage or Compound Document, Microsoft Office).  It is an improved version of
+the OleFileIO module from PIL, the Python Image Library.")
+    (license license:bsd-3)))
+
+(define-public python2-olefile
+  (package-with-python2 python-olefile))
+
 (define-public python-pillow
   (package
     (name "python-pillow")