summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-26 22:01:34 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-26 23:34:10 +0200
commit3f59ecfcb51c6d40bf852ecf6bfa6602704e7936 (patch)
treec1764d6c49de54b004d54ccb94bcd74d71c8c13a
parent152cbc3ca588be8a0db8bd1c9a9746068542e449 (diff)
downloadguix-3f59ecfcb51c6d40bf852ecf6bfa6602704e7936.tar.gz
gnu: ocaml-qcheck: Update to 0.9.
* gnu/packages/ocaml.scm (ocaml-qcheck): Update to 0.9.
-rw-r--r--gnu/packages/ocaml.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b735f47234..2558c01e99 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1183,7 +1183,7 @@ GNU CC attributes.  It provides also a C pretty printer as an example of use.")
 (define-public ocaml-qcheck
   (package
     (name "ocaml-qcheck")
-    (version "0.5.3.1")
+    (version "0.9")
     (source
      (origin
        (method git-fetch)
@@ -1192,10 +1192,13 @@ GNU CC attributes.  It provides also a C pretty printer as an example of use.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0vl2asr7md99pv558nbszxvjj36b4l6rj05hyczfy524vihhl0gf"))))
-    (build-system ocaml-build-system)
+        (base32 "0w83v9ylycsssyn47q8wnkfbvhn5vn10z6i35n5965i2m1r0mmcf"))))
+    (build-system dune-build-system)
+    (arguments
+     `(#:test-target "."))
     (native-inputs
-     `(("ounit" ,ocaml-ounit)
+     `(("ocaml-alcotest" ,ocaml-alcotest)
+       ("ocaml-ounit" ,ocaml-ounit)
        ("ocamlbuild" ,ocamlbuild)))
     (home-page "https://github.com/c-cube/qcheck")
     (synopsis "QuickCheck inspired property-based testing for OCaml")