summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-01-11 22:59:49 +0100
committerLudovic Courtès <ludo@gnu.org>2017-01-11 23:01:54 +0100
commit5c3d6c1da88d67576659567d95b796b391b94f68 (patch)
tree543ca9bb8ac0f0b71753daf585fccccde0628bb8
parent26ab00a0a9c79f85641a305fb13e36476b9a0427 (diff)
downloadguix-5c3d6c1da88d67576659567d95b796b391b94f68.tar.gz
gnu: fprintd: Provide the right file name for 'fprintd.conf'.
* gnu/packages/freedesktop.scm (fprintd)[arguments]: New field.
-rw-r--r--gnu/packages/freedesktop.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 9cfb987976..66060eaa64 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -853,6 +853,18 @@ software.")
                (base32
                 "05915i0bv7q62fqrs5diqwr8dz3pwqa1c1ivcgggkjyw0xk4ldp5"))))
     (build-system gnu-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (add-before 'build 'set-sysconfdir
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      ;; Work around a bug whereby the 'SYSCONFDIR' macro
+                      ;; expands literally to '${prefix}/etc'.
+                      (let ((out (assoc-ref outputs "out")))
+                        (substitute* "src/main.c"
+                          (("SYSCONFDIR, \"fprintd.conf\"")
+                           (string-append "\"" out "/etc\", "
+                                          "\"fprintd.conf\"")))
+                        #t))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)))