summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-14 21:47:45 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-25 19:01:05 +0200
commit6e49426761840e2d45563f4ed4957abcbdf246e5 (patch)
tree087ba9c5858037799a348eeb8a21f64e9e301a48
parent0705f389d1c4321e230cb24e19c8e17bb382582c (diff)
downloadguix-6e49426761840e2d45563f4ed4957abcbdf246e5.tar.gz
gnu: ocamlify: Downgrade to 0.0.1.
Version 0.0.2 cannot be built with the latest OCaml, whereas this
version does.  This is also the version used by opam.

* gnu/packages/ocaml.scm (ocamlify): Downgrade to 0.0.1.
[arguments]: Do not use ocaml-4.02.
-rw-r--r--gnu/packages/ocaml.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 968ba94407..581360af02 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2508,21 +2508,25 @@ radix-64 representation.  It is specified in RFC 4648.")
 (define-public ocamlify
   (package
     (name "ocamlify")
-    (version "0.0.2")
+    (version "0.0.1")
     (source (origin
               (method url-fetch)
-              (uri (ocaml-forge-uri name version 1209))
+              (uri "https://download.ocamlcore.org/ocamlify/ocamlify/0.0.1/ocamlify-0.0.1.tar.gz")
               (sha256
                (base32
-                "1f0fghvlbfryf5h3j4as7vcqrgfjb4c8abl5y0y5h069vs4kp5ii"))))
+                "1j9nb3vjqbdsx3d6jazixgrh776051zkrc06nsc5q5ilp1jhrwkm"))))
     (build-system ocaml-build-system)
     ; tests are done during build
     (arguments
-     `(#:ocaml ,ocaml-4.02
-       #:findlib ,ocaml4.02-findlib
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
-         (delete 'check))))
+         (delete 'check)
+         (replace 'configure
+           (lambda* (#:key outputs #:allow-other-keys)
+             (invoke "ocaml" "setup.ml" "-configure" "--prefix"
+                     (assoc-ref outputs "out")))))))
+    (native-inputs
+     `(("ocamlbuild" ,ocamlbuild)))
     (home-page "https://forge.ocamlcore.org/projects/ocamlify")
     (synopsis "Include files in OCaml code")
     (description "OCamlify allows to create OCaml source code by including