summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-06-17 22:23:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-06-18 18:06:29 +0200
commit7c438099acd19fafb4a14cb2015d5c41e889a2f5 (patch)
tree828a73aefa35e1b355affda10464d9f2571e8477
parente8ac1f8f1fad72a1f5159d47a4f7a0b55557ef1d (diff)
downloadguix-7c438099acd19fafb4a14cb2015d5c41e889a2f5.tar.gz
gnu: Add emacs-multiple-cursors.
* gnu/packages/emacs.scm (emacs-multiple-cursors): New variable.
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index bbb4baa30f..ecefc97bac 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1356,6 +1356,27 @@ front-ends.  Company comes with many back-ends, e.g. @code{company-elisp}.
 These are distributed in separate files and can be used individually.")
     (license license:gpl3+)))
 
+(define-public emacs-multiple-cursors
+  (package
+    (name "emacs-multiple-cursors")
+    (version "1.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/magnars/multiple-cursors.el/"
+                           "archive/" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0hihihlvcvzayg5fnqzcg45fhvlmq6xlq58syy00rjwbry9w389k"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/magnars/multiple-cursors.el")
+    (synopsis "Multiple cursors for Emacs")
+    (description
+     "This package adds support to Emacs for editing text with multiple
+simultaneous cursors.")
+    (license license:gpl3+)))
+
 (define-public typo
   (package
     (name "emacs-typo")