summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-12 22:46:28 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-12 22:52:18 +0100
commit7d9e8c08572f02e3742b759027e2943499ad25de (patch)
treeeb479783386ab831b530f0ef752c1347169ba716
parent1d167b6e3779bcc1666b5c7d5ee802170c7023b6 (diff)
downloadguix-7d9e8c08572f02e3742b759027e2943499ad25de.tar.gz
gnu: guile-reader: Build with the C locale.
* gnu/packages/guile.scm (guile-reader)[arguments]: Add #:locale.
-rw-r--r--gnu/packages/guile.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 9fde9490c1..c605533fd2 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -198,7 +198,13 @@ without requiring the source code to be rewritten.")
     (native-inputs `(("pkgconfig" ,pkg-config)
                      ("gperf" ,gperf)))
     (inputs `(("guile" ,guile-2.0)))
-    (arguments `(#:configure-flags
+    (arguments `(;; The extract-*.sh scripts really expect to run in the C
+                 ;; locale.  Failing to do that, we end up with a build
+                 ;; failure while extracting doc.  (Fixed in Guile-Reader's
+                 ;; repo.)
+                 #:locale "C"
+
+                 #:configure-flags
                  (let ((out (assoc-ref %outputs "out")))
                    (list (string-append "--with-guilemoduledir="
                                         out "/share/guile/site/2.0")))))