summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-26 22:24:54 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-26 23:34:26 +0200
commit853af25ecd1d627bb21da44751d09da776cb4e7c (patch)
treed44331a0c07680ecba22e1e5cfa7ae83d7479ed8
parent3f59ecfcb51c6d40bf852ecf6bfa6602704e7936 (diff)
downloadguix-853af25ecd1d627bb21da44751d09da776cb4e7c.tar.gz
gnu: ocaml-mtime: Update to 1.1.0.
* gnu/packages/ocaml.scm (ocaml-mtime): Update to 1.1.0.
-rw-r--r--gnu/packages/ocaml.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2558c01e99..b267f65e8c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1572,14 +1572,14 @@ manipulate such data.")
 (define-public ocaml-mtime
   (package
     (name "ocaml-mtime")
-    (version "0.8.3")
+    (version "1.1.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://erratique.ch/software/mtime/releases/"
                                   "mtime-" version ".tbz"))
               (sha256
                (base32
-                "1hfx4ny2dkw6jf3jppz0640dafl5xgn8r2si9kpwzhmibal8qrah"))))
+                "1qb4ljwirrc3g8brh97s76rjky2cpmy7zm87y7iqd6pxix52ydk3"))))
     (build-system ocaml-build-system)
     (native-inputs
      `(("ocamlbuild" ,ocamlbuild)
@@ -1588,8 +1588,7 @@ manipulate such data.")
      `(("topkg" ,ocaml-topkg)))
     (arguments
      `(#:tests? #f
-       #:build-flags
-       '("native=true" "native-dynlink=true" "jsoo=false")
+       #:build-flags (list "build" "--with-js_of_ocaml" "false")
        #:phases
        (modify-phases %standard-phases
          (delete 'configure))))